re = /"\b[^"\n]*\b"|\S+/
str = 'sdfj "sdfjjk
sdfj "sdfjjk" "sdfjjk
"sdfjjk sdfj "sdfjjk" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end