import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^;]+)(.*)(?:;)(.*$)?";
final String string = "C05-98-2;2;visakoivu, Betula pendula var. carelica;1100;1350;Hartola;1200;sv2_fi\n"
+ "C05-98-3;3;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv3_fi\n"
+ "C05-98-4;4;visakoivu, Betula pendula var. carelica;1100;1350;Pälkäne;1233;sv4_fi\n"
+ "C05-98-5;5;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv5_fi\n"
+ "C05-98-6;6;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv6_fi";
final String subst = "[/jokupolku/$3.pdf|$1]$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}