import re
regex = re.compile(r"(^[^;]+)(.*)(?:;)(.*$)?", flags=re.MULTILINE)
test_str = ("C05-98-2;2;visakoivu, Betula pendula var. carelica;1100;1350;Hartola;1200;sv2_fi\n"
"C05-98-3;3;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv3_fi\n"
"C05-98-4;4;visakoivu, Betula pendula var. carelica;1100;1350;Pälkäne;1233;sv4_fi\n"
"C05-98-5;5;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv5_fi\n"
"C05-98-6;6;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv6_fi")
subst = "[/jokupolku/$3.pdf|$1]$2"
result = regex.sub(subst, test_str)
if result:
print(result)