const regex = /(^[^;]+)(.*)(?:;)(.*$)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^;]+)(.*)(?:;)(.*$)?', 'gm')
const str = `C05-98-2;2;visakoivu, Betula pendula var. carelica;1100;1350;Hartola;1200;sv2_fi
C05-98-3;3;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv3_fi
C05-98-4;4;visakoivu, Betula pendula var. carelica;1100;1350;Pälkäne;1233;sv4_fi
C05-98-5;5;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv5_fi
C05-98-6;6;visakoivu, Betula pendula var. carelica;1100;1350;Savonlinna;1242;sv6_fi`;
const subst = `[/jokupolku/$3.pdf|$1]$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);