#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z0-9\/\–\?\:\(\)\.\,\‘\+\s]{0,140}"
Local $sString = "Hallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")