$re = '/[a-zA-Z0-9\/\–\?\:\(\)\.\,\‘\+\s]{0,140}/';
$str = 'Hallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);