using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\s)\d{1,3}(?:,\d{3})*(?:,\d+)?(?=\s|$)";
string input = @"980,232 905,903 889,614 881,145 2,343,435 3,435,123 84,325 4,43,52352366 14";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}