import re
regex = re.compile(r"(?<=^|\s)\d{1,3}(?:,\d{3})*(?:,\d+)?(?=\s|$)", flags=re.MULTILINE)
test_str = "980,232 905,903 889,614 881,145 2,343,435 3,435,123 84,325 4,43,52352366 14"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")