using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^hede$(*SKIP)(*F)|";
string substitution = @"";
string input = @"Hoho
Hihi
Haha
hede";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}