const regex = /^hede$(*SKIP)(*F)|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^hede$(*SKIP)(*F)|', 'gm')
const str = `Hoho
Hihi
Haha
hede`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);