use strict;
my $str = 'Hoho
Hihi
Haha
hede';
my $regex = qr/^hede$(*SKIP)(*F)|/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";