using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=prodotti\/).*?(?=\/)";
string input = @"http://www.demo.it/prodotti/822/Panasonic/TXP46G20E.html";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}