$re = '/(?<=prodotti\/).*?(?=\/)/';
$str = 'http://www.demo.it/prodotti/822/Panasonic/TXP46G20E.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);