re = /(?<=prodotti\/).*?(?=\/)/
str = 'http://www.demo.it/prodotti/822/Panasonic/TXP46G20E.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end