#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s+"
Local $sString = " A" & @CRLF & _
"" & @CRLF & _
"B" & @CRLF & _
"" & @CRLF & _
" C"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)