use strict;
my $str = ' A
B
C';
my $regex = qr/^\s+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";