package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+`)
var str = ` A
B
C`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}