const regex = /<script(?!\stype="application\/ld\+json")[^>]*>(.*?)<\/script>/gmis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script(?!\\stype="application\\\/ld\\+json")[^>]*>(.*?)<\\\/script>', 'gmis')
const str = `<script type="text/javascript">document.getElementById("x").innerHTML = "xyz";</script>
<script type="application/javascript">document.getElementById("x").innerHTML = "xyz";</script>
<script>document.getElementById("x").innerHTML = "xyz";</script>
<script type="application/ld+json">{
"@context": "http://schema.org/",
"@type": "Article",
"name": "Some JSON-LD stuff"
}</script>
<SCRIPT TYPE="TEXT/JAVASCRIPT">DOCUMENT.GETELEMENTBYID("X").INNERHTML = "XYZ";</SCRIPT>
<SCRIPT TYPE="APPLICATION/JAVASCRIPT">DOCUMENT.GETELEMENTBYID("X").INNERHTML = "XYZ";</SCRIPT>
<SCRIPT>DOCUMENT.GETELEMENTBYID("X").INNERHTML = "XYZ";</SCRIPT>
<SCRIPT TYPE="APPLICATION/LD+JSON">{
"@CONTEXT": "HTTP://SCHEMA.ORG/",
"@TYPE": "ARTICLE",
"NAME": "SOME JSON-LD STUFF"
}</SCRIPT>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}