import re
regex = re.compile(r"<script(?!\stype=\"application\/ld\+json\")[^>]*>(.*?)<\/script>", flags=re.MULTILINE | re.IGNORECASE | re.DOTALL)
test_str = ("<script type=\"text/javascript\">document.getElementById(\"x\").innerHTML = \"xyz\";</script>\n"
"<script type=\"application/javascript\">document.getElementById(\"x\").innerHTML = \"xyz\";</script>\n"
"<script>document.getElementById(\"x\").innerHTML = \"xyz\";</script>\n"
"<script type=\"application/ld+json\">{\n"
" \"@context\": \"http://schema.org/\",\n"
" \"@type\": \"Article\",\n"
" \"name\": \"Some JSON-LD stuff\"\n"
"}</script>\n"
"<SCRIPT TYPE=\"TEXT/JAVASCRIPT\">DOCUMENT.GETELEMENTBYID(\"X\").INNERHTML = \"XYZ\";</SCRIPT>\n"
"<SCRIPT TYPE=\"APPLICATION/JAVASCRIPT\">DOCUMENT.GETELEMENTBYID(\"X\").INNERHTML = \"XYZ\";</SCRIPT>\n"
"<SCRIPT>DOCUMENT.GETELEMENTBYID(\"X\").INNERHTML = \"XYZ\";</SCRIPT>\n"
"<SCRIPT TYPE=\"APPLICATION/LD+JSON\">{\n"
" \"@CONTEXT\": \"HTTP://SCHEMA.ORG/\",\n"
" \"@TYPE\": \"ARTICLE\",\n"
" \"NAME\": \"SOME JSON-LD STUFF\"\n"
"}</SCRIPT>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")