use strict;
my $str = '<script type="text/javascript">document.getElementById("x").innerHTML = "xyz";</script>
<script type="application/javascript">document.getElementById("x").innerHTML = "xyz";</script>
<script>document.getElementById("x").innerHTML = "xyz";</script>
<script type="application/ld+json">{
"@context": "http://schema.org/",
"@type": "Article",
"name": "Some JSON-LD stuff"
}</script>
<SCRIPT TYPE="TEXT/JAVASCRIPT">DOCUMENT.GETELEMENTBYID("X").INNERHTML = "XYZ";</SCRIPT>
<SCRIPT TYPE="APPLICATION/JAVASCRIPT">DOCUMENT.GETELEMENTBYID("X").INNERHTML = "XYZ";</SCRIPT>
<SCRIPT>DOCUMENT.GETELEMENTBYID("X").INNERHTML = "XYZ";</SCRIPT>
<SCRIPT TYPE="APPLICATION/LD+JSON">{
"@CONTEXT": "HTTP://SCHEMA.ORG/",
"@TYPE": "ARTICLE",
"NAME": "SOME JSON-LD STUFF"
}</SCRIPT>';
my $regex = qr/<script(?!\stype="application\/ld\+json")[^>]*>(.*?)<\/script>/misp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}