#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a.*(<img.*>).*?<\/a>"
Local $sString = "Text Text Text <a href="">Linktext</a> Text Text Text <a href=""><img src=""></a> Test Test Test" & @CRLF & _
"Text Text Text <a href="">Linktext</a><a href=""><img src=""></a> Test Test Test" & @CRLF & _
"Text Text Text <a href=""><img src="">asdf</a> Test Test Test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")