using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*(<img.*>).*?<\/a>";
string input = @"Text Text Text <a href="">Linktext</a> Text Text Text <a href=""><img src=""></a> Test Test Test
Text Text Text <a href="">Linktext</a><a href=""><img src=""></a> Test Test Test
Text Text Text <a href=""><img src="">asdf</a> Test Test Test";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}