package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*(<img.*>).*?<\/a>`)
var str = `Text Text Text <a href="">Linktext</a> Text Text Text <a href=""><img src=""></a> Test Test Test
Text Text Text <a href="">Linktext</a><a href=""><img src=""></a> Test Test Test
Text Text Text <a href=""><img src="">asdf</a> Test Test Test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}