#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)[0-9]+(?!\.\d|[^\s!?.])"
Local $sString = "I have the following products 4526 and 4. The first one I paid $40 while the second one 30€. " & @CRLF & _
"Here the link for the discount of 3.99: https://www.xysyffd.coom/7574@5757"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")