use strict;
my $str = 'I have the following products 4526 and 4. The first one I paid $40 while the second one 30€.
Here the link for the discount of 3.99: https://www.xysyffd.coom/7574@5757';
my $regex = qr/(?<!\S)[0-9]+(?!\.\d|[^\s!?.])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}