re = /(?<!\S)[0-9]+(?!\.\d|[^\s!?.])/m
str = 'I have the following products 4526 and 4. The first one I paid $40 while the second one 30€.
Here the link for the discount of 3.99: https://www.xysyffd.coom/7574@5757'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end