// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<[^>]*").unwrap();
let string = "<p style=\"margin-bottom: 0px; font-stretch: normal; font-size: 14px; line-height: normal; font-family: \"Helvetica Neue\" \">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}