using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\b)?([0-9]{9,11})(\b)?$";
string input = @"102056571
1020565710
10205657100
102056571000
10205657";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}