const regex = /^(\b)?([0-9]{9,11})(\b)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\b)?([0-9]{9,11})(\\b)?$', '')
const str = `102056571
1020565710
10205657100
102056571000
10205657`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}