using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(g|j|jee)\S*(m|м)(a|а|e)?(i|l|j|1)?(l|i|1|e)";
string input = @" gmajI";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}