import re
regex = re.compile(r"(g|j|jee)\S*(m|м)(a|а|e)?(i|l|j|1)?(l|i|1|e)", flags=re.UNICODE | re.IGNORECASE)
test_str = " gmajI"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")