$re = '%(g|j|jee)\S*(m|м)(a|а|e)?(i|l|j|1)?(l|i|1|e)%ui';
$str = ' gmajI';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);