using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)(?=(\d\d\d)+)";
string substitution = @",";
string input = @"12365478965412365";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}