use strict;
my $str = '12365478965412365';
my $regex = qr/(?<=\d)(?=(\d\d\d)+)/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";