$re = '/(?<=\d)(?=(\d\d\d)+)/';
$str = '12365478965412365';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;