using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[)(note)(\])((?:.|[\r\n])*?)(\[)(place)(\])((?:.|[\r\n])*?)(\5)(\/)(\6\7)((?:.|[\r\n])*?)(\1\/\2\3)";
string input = @"å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„
[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place],
[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。
[note][place][/place][/note]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}