import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[)(note)(\\])((?:.|[\\r\\n])*?)(\\[)(place)(\\])((?:.|[\\r\\n])*?)(\\5)(\\/)(\\6\\7)((?:.|[\\r\\n])*?)(\\1\\/\\2\\3)";
final String string = "å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„\n"
+ "[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place],\n"
+ "[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。\n\n"
+ "[note][place][/place][/note]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}