# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[)(note)(\])((?:.|[\r\n])*?)(\[)(place)(\])((?:.|[\r\n])*?)(\5)(\/)(\6\7)((?:.|[\r\n])*?)(\1\/\2\3)"
test_str = ("å°æ˜Žåœ¨[place]å°ç£[/place]耶,[note]å°æ˜Žåœ¨[place]å°åŒ—[/place]çš„\n"
"[place]å—æ¸¯[/place]附近[/note],然後å°çŽ‹ä¹Ÿåœ¨[place]å°ç£[/place],\n"
"[note]å°çŽ‹åœ¨[place]高雄[/place][/note],兩人è·é›¢å¾ˆé 。\n\n"
"[note][place][/place][/note]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.