using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/www.themoviedb.org\/list\/([a-zA-Z0-9\_-]+)$";
string input = @"https://www.themoviedb.org/list/8301863-my-favorite-movies/edit?active_nav_item=step_2
https://www.themoviedb.org/list/8301863-my-favorite-movies
https://www.themoviedb.org/list/8301863-my-favorite-movies/edit";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}