$re = '/^https:\/\/www.themoviedb.org\/list\/([a-zA-Z0-9\_-]+)$/m';
$str = 'https://www.themoviedb.org/list/8301863-my-favorite-movies/edit?active_nav_item=step_2
https://www.themoviedb.org/list/8301863-my-favorite-movies
https://www.themoviedb.org/list/8301863-my-favorite-movies/edit';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);