use strict;
my $str = 'https://www.themoviedb.org/list/8301863-my-favorite-movies/edit?active_nav_item=step_2
https://www.themoviedb.org/list/8301863-my-favorite-movies
https://www.themoviedb.org/list/8301863-my-favorite-movies/edit';
my $regex = qr/^https:\/\/www.themoviedb.org\/list\/([a-zA-Z0-9\_-]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}