#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\w+) \([^()]+\)"
Local $sString = "Boris" & @CRLF & _
"Igor (King)" & @CRLF & _
"Jack (prince of Persia)"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)