package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+) \([^()]+\)`)
var str = `Boris
Igor (King)
Jack (prince of Persia)`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}