use strict;
my $str = 'Boris
Igor (King)
Jack (prince of Persia)';
my $regex = qr/^(\w+) \([^()]+\)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";