import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d{4})-(ACE|AEA|A[AG]L|AN[EM]|AS[WO]|AWP|WT[EW])-(\\d{3,6}.*?)-(OE|NRA)\\b";
final String string = "2019-AWP-7268-OE\n"
+ "2019-AWP-659 THRU 662-NRA\n"
+ "2019-AWP-3823/3825-NRA\n"
+ "2019-AWP-4593/4594/4595/4596-NRA\n"
+ "2019-ASW-4791, 4794 THRU 4796, test - test 4798 THRU 4800-NRA test -NRA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}