// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d{4})-(ACE|AEA|A[AG]L|AN[EM]|AS[WO]|AWP|WT[EW])-(\d{3,6}.*?)-(OE|NRA)\b").unwrap();
let string = "2019-AWP-7268-OE
2019-AWP-659 THRU 662-NRA
2019-AWP-3823/3825-NRA
2019-AWP-4593/4594/4595/4596-NRA
2019-ASW-4791, 4794 THRU 4796, test - test 4798 THRU 4800-NRA test -NRA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}