re = /\b(\d{4})-(ACE|AEA|A[AG]L|AN[EM]|AS[WO]|AWP|WT[EW])-(\d{3,6}.*?)-(OE|NRA)\b/m
str = '2019-AWP-7268-OE
2019-AWP-659 THRU 662-NRA
2019-AWP-3823/3825-NRA
2019-AWP-4593/4594/4595/4596-NRA
2019-ASW-4791, 4794 THRU 4796, test - test 4798 THRU 4800-NRA test -NRA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end