using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?\s.*?)\s.*";
string substitution = @"\1";
string input = @"eskitirim eski[Verb]-t[Verb+Caus]+[Pos]+Hr[Aor]+YHm[A1sg] : 20.4453125 eski[Verb]-t[Verb+Caus]+[Pos]+Hr[Aor]+Hm[A1sg] : 21.7978515625";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}