import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?\\d{1,3}(?:[,.]\\d{3})*[.,]\\d{2}$";
final String string = "2\n"
+ " // no match\n"
+ "29.2\n"
+ " // no match\n"
+ "2.48\n"
+ "8.06.16\n"
+ " // no match\n"
+ "-2.41\n"
+ "-.54\n"
+ " // no match\n"
+ "4.492\n"
+ " // no match\n"
+ "4.194,32\n"
+ "39,299.39\n"
+ "329.382,39\n"
+ "-188.392,49\n"
+ "293.392,193\n"
+ " // no match\n"
+ "-.492.183,33'\n"
+ " // no match\n"
+ "3.492.249,11\n"
+ "29.439.834,13\n"
+ "-392.492.492,43\n"
+ "8.06.16\n"
+ " // no match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}