// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?\d{1,3}(?:[,.]\d{3})*[.,]\d{2}$").unwrap();
let string = "2
// no match
29.2
// no match
2.48
8.06.16
// no match
-2.41
-.54
// no match
4.492
// no match
4.194,32
39,299.39
329.382,39
-188.392,49
293.392,193
// no match
-.492.183,33'
// no match
3.492.249,11
29.439.834,13
-392.492.492,43
8.06.16
// no match";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}